re = /##\K[A-Z]+(?:_[A-Z]+)*(?=##)/m
str = 'class: ##TOPIC##-area
name: myClass
type: Class
secretKey: private-##SECRET_KEY##-encoded-##SUFFIX_CODE##'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end