package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)From: [a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+|([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)`)
var str = `18.4.2019 9:35:02.115(22)->:From: address@subdomain.domain.tld RCPT TO:<test@domain.tld>
RCPT TO:<address@domain.tld>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}