$re = '/From: [a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+|([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)/m';
$str = '18.4.2019 9:35:02.115(22)->:From: address@subdomain.domain.tld RCPT TO:<test@domain.tld>
RCPT TO:<address@domain.tld>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);