use strict;
my $str = '<table class="test">
<tr>
<td>bla bla bla</td>
</tr>
</table>';
my $regex = qr/<table\b.*?\bclass\s*=\s*(['"]).*?\btest\b.*?\1.+?<\/table>/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}