#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(build|ci|docs|feat|fix|perf|refactor|style|test)(|!): [a-z].+?((, fixes #\d+)*)($|\n|\r|\n\r)"
Local $sString = "Remove 'ddev pause' and its tests" & @CRLF & _
"" & @CRLF & _
"Add healthcheck to router so we wait for it to be started" & @CRLF & _
"" & @CRLF & _
"Add new Amplitude Property DDEV-Environment" & @CRLF & _
"" & @CRLF & _
"test: optimize caching of downloaded assets" & @CRLF & _
"" & @CRLF & _
"docs: auto create commands documentation" & @CRLF & _
"" & @CRLF & _
"docs: re-introduce Rancher Desktop docs" & @CRLF & _
"" & @CRLF & _
"fix: avoid type: php to detected project type but instead show a warning, fixes #4403, fixes #1234" & @CRLF & _
"build: bump docker-compose to 2.19.0" & @CRLF & _
"" & @CRLF & _
"feat: allow multiple upload dirs, fixes #4190, fixes #4796" & @CRLF & _
"" & @CRLF & _
"feat!: add ddev dbeaver command, fixes #4947" & @CRLF & _
"" & @CRLF & _
"docs: add more extensive custom command examples, fixes #4926" & @CRLF & _
"" & @CRLF & _
"refactor: enabled Mutagen by default on Mac and Windows, fixes #4637" & @CRLF & _
"" & @CRLF & _
"refactor: avoid calling stop hooks if app is already stopped" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")