re = /^(build|ci|docs|feat|fix|perf|refactor|style|test)(|!): [a-z].+?((, fixes #\d+)*)($|\n|\r|\n\r)/m
str = 'Remove \'ddev pause\' and its tests
Add healthcheck to router so we wait for it to be started
Add new Amplitude Property DDEV-Environment
test: optimize caching of downloaded assets
docs: auto create commands documentation
docs: re-introduce Rancher Desktop docs
fix: avoid type: php to detected project type but instead show a warning, fixes #4403, fixes #1234
build: bump docker-compose to 2.19.0
feat: allow multiple upload dirs, fixes #4190, fixes #4796
feat!: add ddev dbeaver command, fixes #4947
docs: add more extensive custom command examples, fixes #4926
refactor: enabled Mutagen by default on Mac and Windows, fixes #4637
refactor: avoid calling stop hooks if app is already stopped
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end