import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[a-z]+(?:_[A-Z]+)?(?:_\\d+)?\\b|\\b(?:[a-z]+_)?(?:[A-Z]+_)?\\d+\\b|\\b[A-Z]+\\b";
final String string = "az\n"
+ "AZ\n"
+ "09\n"
+ "az_09\n"
+ "AZ_09\n"
+ "az_AZ\n\n"
+ "az__\n"
+ "_AZ_\n"
+ "__09\n"
+ "az__09\n"
+ "_AZ_09\n"
+ "az_AZ_";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}