$re = '/\b[a-z]+(?:_[A-Z]+)?(?:_\d+)?\b|\b(?:[a-z]+_)?(?:[A-Z]+_)?\d+\b|\b[A-Z]+\b/';
$str = 'az
AZ
09
az_09
AZ_09
az_AZ
az__
_AZ_
__09
az__09
_AZ_09
az_AZ_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);