$re = '/[0-9]+\h+Vehicles(?!\h+have\b)/m';
$str = '3 Vehicles have already been added
13 Vehicles';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);