re = /[0-9]+\h+Vehicles(?!\h+have\b)/m
str = '3 Vehicles have already been added
13 Vehicles'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end