#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+[.\/]?\d+|\d+"
Local $sString = ""47 g (0.25 cup)"" & @CRLF & _
"" & @CRLF & _
""47 g (0.25 cup)"" & @CRLF & _
"" & @CRLF & _
""56 g (0.5 cup)"" & @CRLF & _
"" & @CRLF & _
""40 g (0.25 cup)"" & @CRLF & _
"" & @CRLF & _
""2 SLICES (57 g)"" & @CRLF & _
"" & @CRLF & _
""3.0g"" & @CRLF & _
"" & @CRLF & _
""serving"" & @CRLF & _
"" & @CRLF & _
""1 ARTICHOKE, EDIBLE (120 g)"" & @CRLF & _
"" & @CRLF & _
""1/4 pizza (133 g)"" & @CRLF & _
"" & @CRLF & _
""1 pizza 52 g"" & @CRLF & _
"" & @CRLF & _
""42 g (0.5 DRY NOODLE BLOCK AND 1 TSP SEASONING MIX | ABOUT)"" & @CRLF & _
"" & @CRLF & _
""4 COOKIES, PER CONTAINER ABOUT (15 g)"" & @CRLF & _
"" & @CRLF & _
""15 ASSORTED NUTS | APPROX. (30 g)"" & @CRLF & _
"" & @CRLF & _
""Per 1 piece (1.9 g)"" & @CRLF & _
"" & @CRLF & _
""1 piece (1.9 g) (1.9 g)"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")