import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+[.\\/]?\\d+|\\d+";
final String string = "\"47 g (0.25 cup)\"\n\n"
+ "\"47 g (0.25 cup)\"\n\n"
+ "\"56 g (0.5 cup)\"\n\n"
+ "\"40 g (0.25 cup)\"\n\n"
+ "\"2 SLICES (57 g)\"\n\n"
+ "\"3.0g\"\n\n"
+ "\"serving\"\n\n"
+ "\"1 ARTICHOKE, EDIBLE (120 g)\"\n\n"
+ "\"1/4 pizza (133 g)\"\n\n"
+ "\"1 pizza 52 g\"\n\n"
+ "\"42 g (0.5 DRY NOODLE BLOCK AND 1 TSP SEASONING MIX | ABOUT)\"\n\n"
+ "\"4 COOKIES, PER CONTAINER ABOUT (15 g)\"\n\n"
+ "\"15 ASSORTED NUTS | APPROX. (30 g)\"\n\n"
+ "\"Per 1 piece (1.9 g)\"\n\n"
+ "\"1 piece (1.9 g) (1.9 g)\"\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}