#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z]\d{2,4}(?:-[a-z]\d{2,4})?(?:-[a-z])?"
Local $sString = "/s1600/" & @CRLF & _
"/s1600-c/" & @CRLF & _
"/w80-h50/" & @CRLF & _
"/w300-h480-c/" & @CRLF & _
"/w80/" & @CRLF & _
"/w80-c/" & @CRLF & _
"/h50/" & @CRLF & _
"/h50-c/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")