import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z]\\d{2,4}(?:-[a-z]\\d{2,4})?(?:-[a-z])?";
final String string = "/s1600/\n"
+ "/s1600-c/\n"
+ "/w80-h50/\n"
+ "/w300-h480-c/\n"
+ "/w80/\n"
+ "/w80-c/\n"
+ "/h50/\n"
+ "/h50-c/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}