$re = '/^[A-Za-zÀ-ÖØ-öø-ÿ][A-Za-z0-9À-ÖØ-öø-ÿ]*(?:[ _][A-Za-z0-9À-ÖØ-öø-ÿ]+)+$/m';
$str = 'RegExr was created by gskinner_com_and is proudly hosted by Media Temple
RegExr was created by gskinner_com_and is proudly hosted by Media Temple';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);