import re
regex = re.compile(r"^[A-Za-zÀ-ÖØ-öø-ÿ][A-Za-z0-9À-ÖØ-öø-ÿ]*(?:[ _][A-Za-z0-9À-ÖØ-öø-ÿ]+)+$", flags=re.MULTILINE)
test_str = ("RegExr was created by gskinner_com_and is proudly hosted by Media Temple\n\n"
"RegExr was created by gskinner_com_and is proudly hosted by Media Temple")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")