const regex = /Bildschirmgröße=[^(]*\(\s*\K\d[\d,]*\s+\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Bildschirmgröße=[^(]*\\(\\s*\\K\\d[\\d,]*\\s+\\w+', 'gm')
const str = `Anschlüsse/Schnittstellen=(USB 3.0)|Bildschirmgröße=59,9 cm (23,6 Zoll)|Bluetooth=Bluetooth 4.0|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}