re = /Bildschirmgröße=[^(]*\(\s*\K\d[\d,]*\s+\w+/m
str = 'Anschlüsse/Schnittstellen=(USB 3.0)|Bildschirmgröße=59,9 cm (23,6 Zoll)|Bluetooth=Bluetooth 4.0|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end