package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\|\s(.[^|]+)\s\|`)
var str = `| | |
|---|---|
| Answering Machine Messages | When the system is set up to detect answering machines on outbound calls, and it detects one, then it plays this message for the customer to listen later on. |
| Connect Messages | Message played/sent to the caller immediately before delivering call to the selected operator. |`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}