use strict;
my $str = '| | |
|---|---|
| Answering Machine Messages | When the system is set up to detect answering machines on outbound calls, and it detects one, then it plays this message for the customer to listen later on. |
| Connect Messages | Message played/sent to the caller immediately before delivering call to the selected operator. |';
my $regex = qr/^\|\s(.[^|]+)\s\|/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}