package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`</?(\w+)>`)
var str = `<a \n name=toc>table of contents</a>
<b>hello</b> world!
<HTML>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}