$re = '/</?(\w+)>/';
$str = '<a \\n name=toc>table of contents</a>
<b>hello</b> world!
<HTML>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);