const regex = /<img([\w\W]+?)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img([\\w\\W]+?)>', 'g')
const str = `<img src="test.jpg"><p>some text</p><img src="test.jpg">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}