import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<MyLastParagraph>.*\\s)$";
final String string = "gula. Morbi tincidunt purus ac pharetra vehicula. Aenean convallis tristique eros hendrerit porttitor.\n\n"
+ "Morbi tristique massa ligula, vel interdum dui ultricies hendrerit. In blandit ultrices arcu, et accumsan nulla bibendum sed.\n\n"
+ "Proin quis tortor lacinia, ullamcorper nisl eget, pharetra tellus. Aenean in imperdiet lectus, vel tempus sem.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}