// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<MyLastParagraph>.*\s)$").unwrap();
let string = "gula. Morbi tincidunt purus ac pharetra vehicula. Aenean convallis tristique eros hendrerit porttitor.
Morbi tristique massa ligula, vel interdum dui ultricies hendrerit. In blandit ultrices arcu, et accumsan nulla bibendum sed.
Proin quis tortor lacinia, ullamcorper nisl eget, pharetra tellus. Aenean in imperdiet lectus, vel tempus sem.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}