#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([@#](?=[^aeiou]{7,13}$)(?=[[:alnum:]]{7,13}$)(?=.*[A-Z]{1,}.*$).+)$"
Local $sString = "@ssgWds1" & @CRLF & _
"_rth521q" & @CRLF & _
"#mKK51d7" & @CRLF & _
"@WW65" & @CRLF & _
"@Qsgwd32" & @CRLF & _
"#kTl45e7" & @CRLF & _
"#fg48Ehs" & @CRLF & _
"@rt51gwq" & @CRLF & _
"#555wrWE" & @CRLF & _
"@qz6P$ww"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")