package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-[:alpha:] ]{2,100}$`)
var str = `Åland Islands
Afghanistan
Côte dIvoire
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}