$re = '/^[-[:alpha:] ]{2,100}$/m';
$str = 'Åland Islands
Afghanistan
Côte dIvoire
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);