$re = '/\((\(*(?:[^)(]*|\([^)]*\))*\)*)\)/m';
$str = 'Foo ( test1 test2 )
test2 Bar ( test1 t3() test2 )
((("Fdsfds")))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);