package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^e\n]*e){2}[^\ne]*$`)
var str = `agre
feel
degree`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}