$re = '/^(?:[^e\n]*e){2}[^\ne]*$/m';
$str = 'agre
feel
degree';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);