$re = '/(^|\W|\b)"@(\W|\b|$)/m';
$str = '"@#bar {}qux';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);