import re
regex = re.compile(r"((((\d{1,3}\.){2}\d{1,3})\[\.\])(\d{1,3}))\,(\d{1,5})?\/?(\d{1,5})?")
test_str = ("185.106.121[.]118,\n"
"133.100.202[.]85,443\n"
"185.106.121[.]66,\n"
"82.211.30[.]195,\n"
"95.183.53[.]36,\n"
"84.200.17[.]144,\n"
"107.161.178[.]46,53/443\n"
"190.117.186[.]171,443\n"
"109.230.199[.]54,\n"
"87.98.179[.]18,57421\n"
"76.9.60[.]204,\n"
"125.214.195[.]17,\n"
"131.72.139[.]118,\n"
"196.29.166[.]218,\n"
"37.228.151[.]133,\n"
"37.10.71[.]99,\n"
"202.145.16[.]4,\n"
"133.94.1[.]3,\n"
"163.22.20[.]4,\n"
"210.135.90[.]41,\n"
"139.18.13[.]2,\n"
"212.19.128[.]4,\n"
"134.19.176[.]150,7777\n"
"185.101.34[.]122,6478\n"
"185.101.34[.]74,5367\n"
"185.25.51[.]246,\n"
"46.100.250[.]10,\n"
"62.201.235[.]227,\n"
"67.65.229[.]53,\n"
"188.165.149[.]249,\n"
"208.92.93[.]212,\n"
"209.239.123[.]75,\n"
"137.175.19[.]153,37779\n"
"http://doladolaladont[.]com,\n"
"https://alphanoun[.]bit/forum/ajax.php,\n"
"http://coffeol[.]com/fend/raw_server.exe,\n"
"http://inpend-traij[.]net/aka.doc,\n"
"http://twlnco[.]com/gskf/online.php,\n"
"https://a.pomf[.]cat/wryvpl.exe,\n"
"https://filesblog[.]bit/blog/ajax.php,\n"
"http://egonbute.duckdns[.]org,5588\n"
"http://kampolento.ddns[.]net,1825\n"
"http://memeku.ddns[.]net,1825\n"
"http://sap.misapor[.]ch,443\n"
"http://update.toythieves[.]com,8080\n"
"http://workhard231.hopto[.]org,7070/8821\n"
"http://www.eye-watch[.]in,\n"
"https://channel.jetos[.]com,443\n"
"https://mcf.otzo[.]com,443\n"
"https://onlink.epac[.]to,443\n"
"https://repview.ignorelist[.]com,443\n"
"https://sap.misapor[.]ch,443\n"
"https://statis.ignorelist[.]com,443\n"
"https://update.toythieves[.]com,443\n"
"http://piezasrazonable[.]com,80\n"
"http://wmi.mykings[.]top,\n"
"http://js.mykings[.]top:280/v.srt,280\n"
"http://wmi.mykings[.]top:8888/test.html,8888\n"
"http://wmi.mykings[.]top:8888/kill.html,8888\n"
"http://coffeol[.]com/fend/lll.exe,\n")
subst = "$3.$5"
result = regex.sub(subst, test_str)
if result:
print(result)