const regex = /\b(jack)[\s&-]*(?:(?:n|and)[\s&-]*)?(jill)\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(jack)[\\s&-]*(?:(?:n|and)[\\s&-]*)?(jill)\\b', 'gi')
const str = ` jackjill | jack jill | jack-jill | jack&jill | jack & jill | jack-&-jill | jack and jill | jackandjill | jack-and-jill | jack n jill jack knows Jill`;
const subst = `$1 & $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);