re = /\b(jack)[\s&-]*(?:(?:n|and)[\s&-]*)?(jill)\b/i
str = ' jackjill | jack jill | jack-jill | jack&jill | jack & jill | jack-&-jill | jack and jill | jackandjill | jack-and-jill | jack n jill jack knows Jill'
subst = '$1 & $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result