import re
regex = re.compile(r"^(VI[0-9]{4}(?:BV)?(?:\d{2})?(D|H|MIN|MAX)?)+$", flags=re.MULTILINE)
test_str = ("6789\n"
"VI2111\n"
"VI2122\n"
"VI2122MIN\n"
"VI2122MAX\n"
"VI2122MUN\n"
"VI210021\n"
"VI210021D\n"
"VI210021H\n"
"VI210021X\n"
"VI2100BVMIN\n"
"VI2100BVMAX\n"
"VI2100\n"
"VI21001")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")