# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*? (?=interesting\b)//gm;t' <<< "The text is interesting but short
The text is short"