$re = '/.*? (?=interesting\b)/m';
$str = 'The text is interesting but short
The text is short';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;