import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*((https?)://(www\\.)?twitter\\.com/[^.\\s]+)";
final String string = "[15:47] <bb> I'm just going to keep them coming https://twitter.com/sarahbryant_/status/791002091045130240?lang=en\n"
+ "[15:49] <zz> hmmmmmm test https://twitter.com/randygdub/status/525142857015762944?lang=en\n"
+ "[15:49] <zz> https://twitter.com/sarahbryant_/status/791002091045130240?lang=en\n"
+ "[15:49] <aa> Tweet: I just found this on someone's car....\n"
+ "[15:52] <zz> https://twitter.com/sarahbryant_/status/791002091045130240?lang=en test 3\n"
+ "[15:52] <aa> Tweet: I just found this on someone's car....\n"
+ "[15:52] <zz> test4 pls test https://twitter.com/sarahbryant_/status/791002091045130240?lang=en test 3((https?)://(www\\.)?twitter\\.com/[^.\\s]+)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}