const regex = new RegExp('.*((https?)://(www\\.)?twitter\\.com/[^.\\s]+)', 'g')
const str = `[15:47] <bb> I'm just going to keep them coming https://twitter.com/sarahbryant_/status/791002091045130240?lang=en
[15:49] <zz> hmmmmmm test https://twitter.com/randygdub/status/525142857015762944?lang=en
[15:49] <zz> https://twitter.com/sarahbryant_/status/791002091045130240?lang=en
[15:49] <aa> Tweet: I just found this on someone's car....
[15:52] <zz> https://twitter.com/sarahbryant_/status/791002091045130240?lang=en test 3
[15:52] <aa> Tweet: I just found this on someone's car....
[15:52] <zz> test4 pls test https://twitter.com/sarahbryant_/status/791002091045130240?lang=en test 3((https?)://(www\\.)?twitter\\.com/[^.\\s]+)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}