using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|,)[^,|]*\K\|{2,}(?=[^,|]*(?:,|$))";
string input = @"||| ABC, XYZ, |||,|||||, ||G|F|,1|2,||||, R|T|Y, ||";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}