$re = '/(?:^|,)[^,|]*\K\|{2,}(?=[^,|]*(?:,|$))/m';
$str = '||| ABC, XYZ, |||,|||||, ||G|F|,1|2,||||, R|T|Y, ||';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);