#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*(NOTE)"
Local $sString = "# VSCode TODO Tree regex" & @CRLF & _
"" & @CRLF & _
"// NOTE: lorem ipsum" & @CRLF & _
"" & @CRLF & _
" * NOTE: this is a test" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"* NOTE" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"- Original Regex:" & @CRLF & _
"(//|#|<!--|;|/\*|^|^\s*(-|\d+.))\s*($TAGS)" & @CRLF & _
"" & @CRLF & _
"- Updated to also find " & @CRLF & _
"(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*($TAGS)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")