import re
regex = re.compile(r"(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*(NOTE)", flags=re.MULTILINE)
test_str = ("# VSCode TODO Tree regex\n\n"
"// NOTE: lorem ipsum\n\n"
" * NOTE: this is a test\n\n"
"/*\n"
"* NOTE\n"
"*/\n\n"
"- Original Regex:\n"
"(//|#|<!--|;|/\\*|^|^\\s*(-|\\d+.))\\s*($TAGS)\n\n"
"- Updated to also find \n"
"(\\/\\/|#|<!--|;|\\s?\\*\\s?|^|^\\s*(-|\\d+.))\\s*($TAGS)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")