use strict;
my $str = 'compile group: \'commons-net\', name: \'commons-net\', version: \'3.1.2\'
testCompile group: \'org.spockframework\', name: \'spock-core\', version: \'2.0-M1-groovy-3.0\'
implementation group: \'commons-net\', name: \'commons-net\', version: \'3.7.2\'
testImplementation group: \'org.spockframework\', name: \'spock-core\', version: \'2.0-M4-groovy-3.0\'
implementation "org.apache.httpcomponents:httpclient:latest.release"
implementation \'org.apache.httpcomponents:httpclient:1.0.0\'
compile "com.h2database:h2:1.4.197"
compile("com.github.bkenn:kfoenix:0.1.2-SNAPSHOT")
compile group: "com.jfoenix", name: "jfoenix", version: "8.0.7"
compile "org.jooq:jooq:3.11.5"
jooqRuntime(\'com.h2database:h2:1.4.197\')
jooqRuntime("com.h2database:h2:1.4.197")
jooqRuntime \'com.h2database:h2:1.4.197\'
jooqRuntime "com.h2database:h2:1.4.197"';
my $regex = qr/(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\sgroup\:\s['"](.*)['"],\sname\:\s['"](.*)['"],\sversion\:\s['"](.*)['"]|(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\s['"](.*):(.*):(.*)['"]|(compile|testCompile|implementation|testImplementation|compileOnly|runtime|testRuntime|[a-zA-Z0-9_]{1,100})\(['"](.*):(.*):(.*)['"]\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}