$re = '/(?<==)([\'"])?[^\'"]+(?(1)\1|\s)/m';
$str = 'incoming_username=tomek incoming_username=\'tomek\' incoming_username="tomek" incoming_username=\'tomek1 i ala\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);