re = /(?<==)(['"])?[^'"]+(?(1)\1|\s)/m
str = 'incoming_username=tomek incoming_username=\'tomek\' incoming_username="tomek" incoming_username=\'tomek1 i ala\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end