$re = '`^.*?/\..*?$|^.*?\.(lock)?$|^[^/]+$|^.*?\.\..*?$|^.*?[\000-\037\177 ~^:?*[]+.*?$|^\..*?$|^.*?/$|^.*?//.*?$|^.*?@\{.*?$|^@$|^.*?\\\\.*?$`m';
$str = 'not/.allowed
this/ends/in.lock
hasnopath
has/to..do/dots
.starts/with/a/dot
ends/with/
has//slash
ends/with/dot.
has/con@{trol/chars
has/a\\.bad/setup';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);