re = /^.*?\/\..*?$|^.*?\.(lock)?$|^[^\/]+$|^.*?\.\..*?$|^.*?[\000-\037\177 ~^:?*[]+.*?$|^\..*?$|^.*?\/$|^.*?\/\/.*?$|^.*?@\{.*?$|^@$|^.*?\\.*?$/m
str = 'not/.allowed
this/ends/in.lock
hasnopath
has/to..do/dots
.starts/with/a/dot
ends/with/
has//slash
ends/with/dot.
has/con@{trol/chars
has/a\\.bad/setup'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end