package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[2-9]{1}[0-9]{9}$`)
var str = `2548765425`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}